Jump to content

Welcome to INSYDIUM ONLINE

The place to talk about X-Particles and Cycles 4D

ollyvenning

Animated texture map not rendering

Recommended Posts

Hey there. I've been having an odd issue in Cycles, where it has stopped rendering animated texture maps, e.g. an image sequence. It updates in the viewport, and even in the node editor, but not in the real-time preview or when I hit render.

Weirdly, it was working last week, and just seems to have stopped. Anyone had a similar problem or any ideas? Have I hit some weird secret button, or does this sound like a bug?

I'm running R18 and CYcles v. 1.0.0247

I couldn't upload all of the image sequences, but I've uploaded a scene, just stick any image sequence in the texture slot if you'e able to take a look.

As I said, the odd thing is, a week ago this was working fine, so I'm not sure if there's a global preference of something I've switched?

Thanks in advance :)

 

 

CYclesTextMap.c4d

Share this post


Link to post
Share on other sites
57 minutes ago, ollyvenning said:

Hey there. I've been having an odd issue in Cycles, where it has stopped rendering animated texture maps, e.g. an image sequence. It updates in the viewport, and even in the node editor, but not in the real-time preview or when I hit render.

Weirdly, it was working last week, and just seems to have stopped. Anyone had a similar problem or any ideas? Have I hit some weird secret button, or does this sound like a bug?

I'm running R18 and CYcles v. 1.0.0247

I couldn't upload all of the image sequences, but I've uploaded a scene, just stick any image sequence in the texture slot if you'e able to take a look.

As I said, the odd thing is, a week ago this was working fine, so I'm not sure if there's a global preference of something I've switched?

Thanks in advance 🙂

 

 

CYclesTextMap.c4d

you need to turn on the animate checkbox in the image texture node.

Share this post


Link to post
Share on other sites
4 minutes ago, Mohamed Sakr said:

you need to turn on the animate checkbox in the image texture node.

Thanks Mohamed, Feel stupid I overlooked this! It's just strange how I had it working before, and even when I open the files where it previously worked, it didn't anymore... That's why I thought it couldn't have been a checkbox. Ah well, thanks for your quick reply, really appreciated 🙂

Share this post


Link to post
Share on other sites
27 minutes ago, Mohamed Sakr said:

you need to turn on the animate checkbox in the image texture node.

Hi, actually I am still having a problem, I can see what it is now.

I'm using XParticles, and emitting the particles from a plane with an animated texture map, so the particles colours change over time. The emiiter is set to emit from Texture.

When using a standard c4d shader, the animated texture map doesn't update in the render, but the particles are coloured (just the colour of the first frame of iage sequence)

If I use the cycles shader, with an animated texture map, no particles are rendered at all.

For the particles themselves, I am using a Particle Info node, and the colour channel. I've attached my scene, again without the texture maps.

Thanks again in advance!

VanG_Portrait_cyc_v08.c4d

Share this post


Link to post
Share on other sites
4 minutes ago, ollyvenning said:

Hi, actually I am still having a problem, I can see what it is now.

I'm using XParticles, and emitting the particles from a plane with an animated texture map, so the particles colours change over time. The emiiter is set to emit from Texture.

When using a standard c4d shader, the animated texture map doesn't update in the render, but the particles are coloured (just the colour of the first frame of iage sequence)

If I use the cycles shader, with an animated texture map, no particles are rendered at all.

For the particles themselves, I am using a Particle Info node, and the colour channel. I've attached my scene, again without the texture maps.

Thanks again in advance!

VanG_Portrait_cyc_v08.c4d

did you cache the particles? if particles are not cached it won't work

Share this post


Link to post
Share on other sites
11 minutes ago, Mohamed Sakr said:

did you cache the particles? if particles are not cached it won't work

Hi, I just tried caching the particles, it still didn't work - they don't render at all

EDIT -  OK I see now, I have to use a standard c4D shader for the emitter texture, but it has to be cached! I was trying to use a cycles shader as the emitter texture, which doens;t work, even when cached. Problem solved, thanks again for your help 🙂

Edited by ollyvenning

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×