Jump to content

Welcome to INSYDIUM Online

The place to talk about X-Particles and Cycles 4D

Sign in to follow this  
trigger adam

xpTrail + Sweep Nurb / Missing geometry in first frame using Team Render

Recommended Posts

Hello:

I have a sweep nurb using an xpTrail object to create some animated geometry.  Specifically, when I use xpCache and my team render clients, the *sometimes* are missing the first frame of the sweep nurb geometry.  The second frame picks it up just fine.  Everything works with xpCache and team render just fine.  All the xpCache files are found in the shared network.  It's just that when the client picks the render (rq), the first frame has no data for the xpTrail I think?  I tried this with the openVDBMesher, and it's fine.  It's something about the sweep nurb.

Also worth noting, I tried playing with priorities, and putting things higher up in the object manager.  Didn't seem to work.  I even tried the "Set Priority" tag, but I don't thing it actually effects anything but some animation stuff.

When the client picks up a new range, the same thing happens, the first frame is missing the sweep nurb geometry.  Second frame and till the end, is fine.  So as the frame ranges get moved around, I end up with a bunch of frames missing the sweep nurb + xpCache geometry for each start of a new range on any one of my clients.

I believe, oddly, that if I team render to just my local machine, the same thing happens.  If I DONT use team render, it's fine.  So... there's that.

Finally, I have the "skip pre-roll" unchecked.  I think this concerned me.. but it also isn't making a difference.

I'm out of ideas.  Anyone have any thoughts?

xpart.c4d

Share this post


Link to post
Share on other sites

Hello:

Some insight, as I try and figure this out.

1: This is tied only to Team Render, even if it's on the same machine.

2: It's tied to Physical Render, as Standard works fine.

3: It's connected to High Q, I think.  I unchecked it at some point and it rendered ok, but then it inexplicably stopped rendering ok.  I'm not sure what I did, but I can't get it back.

4: It's only with xpCache, again even on the same machine.  If I render with team render NO cache... it's fine.

: Oddly, I have another file that uses xpTrail, I use a sweep nurb, uses xpCache w/ external files, and it's rendering fine.  But I cannot re-create even the most basic file and have it work, so not sure how that file is different other than I created it in R19 last year.  

My feeling is that somehow the xpCache is getting read or written incorrectly based on something Physical Render is looking for.  So, no matter what the range of frames (say 50-60), it isn't finding the cache file the first frame, even though it's loaded correctly (as indicated in the console log).

I'm including this basic file with no bells or whistles, just a basic emitter, sweep nurb, and xpCache.  You'll have to build/use an xpCache to see that it wont render frame 50, even though the geometry is well established.Test-Basic-Sweep.c4d

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×