Jump to content

Welcome to INSYDIUM ONLINE

The place to talk about X-Particles and Cycles 4D

vicnorman

Fluids not working with small scenes

Recommended Posts

I've been trying to do a fairly simple suryp like simulation in several versions of xaprticles (its a client request that pops up every now and then) and failing every time. I was really hoping that this would get easier with every new version of xparticles but I just cant get it.

The problem is that I like to work in real world scale, and Im working with product shots so most of the time im dealing with objects that are just a few centimeters tall. Right now Ive got an ice cream that needs to have suryp poured over it and the scale of the project seems to be throwing x particles way off. Xparticles just doesn't act the same wit small values.

first, I need a small stream of liquids som my emitter is .2 cm with emission set to hexagonal and a particle radius of .008 cm. I'd like to have a much more dense particle stream but lowering the particle radius more just slows down the sim to a grinding halt and doesnt seem to generate a whole lot more particles.

normal gravity at this scale makes particles move way too fast so I set to about 500 cm. Doesnt seem optimal

Viscosity is set to max value in xpConstraints and FLuidPBD, but still doesnt really do the trick. 

Now I've followed som tutorials on simple viscous fluids and with "standard" scales everything changes and seems to work much more as expected. I can get much denser particle streams and really viscous simulations that compute much much faster with emitter that have a 10-20 cm radius, interacting with objects that are 100 cm's tall for example. Why is this and whats the solution?

Do I have to scale everything up? Seems really counterintuitive, and since I'm rendering with Redshift, is gonna throw everything else off.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I got exact the same issue  - found no answer so far. Come on Insydium Community,  help us out here!

Edited by illd

Share this post


Link to post
Share on other sites

Hi Guys 

Ill give you a little run down on whats happening. 

So first off scene scale is not in fact an issue what is the issue is simulation settings. @vicnorman you were on track with Gravity. whats happening is the particles are moving to fast due to the scene scale and the Gravity.

If they move in steps greater than the SPH radius the simulation wont work. so things to look at are gravity speed and substeps lets have a look.

Here's a scene with a real world sized glass and particle radius of .1 as you can see its not working as you expect it too.

So lets change the gravity strength right down to 100.

a6EcldR.png

We get this much better already.

Now we want to make it fill up more so lets do a couple of things.

First increasing the particle radius will help fill a glass more. However that will make the solver more explosive so to combat that in the FluidFX object enable "Check Density" 

So in this scene we set the radius up to .4

ce14vCR.png

And this is the result.

 

One more thing to try out you may not need it is to increase the scene substeps in this iv increased it to 3.

zNFS5rm.png

The result is a little more realistic.

As you can see much closer to what you expect and still using the real world scene scales. 

Hope that helps.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  • Like 3

Share this post


Link to post
Share on other sites

Thank you so much for this  explanation Mike, I will give it  a try asap. Maybee Insydium should ad this to the Manuall...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×