Jump to content

Welcome to INSYDIUM ONLINE

The place to talk about X-Particles and Cycles 4D

Sign in to follow this  
Richard Squires

XP Dynamics set up

Recommended Posts

Having watched the presentation introducing XP Shatter I was really excited to try it out. But I think I am missing something. I have added a Shatter object and made a sphere a child. This is being fractured by shatter. I then add an XP Dynamics tag to the Shatter object and have added an emitter so I assume it's set up correctly. I also added a gravity modifier so the Sphere drops to a plane object with an xp collision tag attached. The problem I have is that the shatter object doesn't seem to be interacting with itself and the surface of the collision item seems to be way above its actual position. Know its early access so I imagine its a bug or I don't know what I'm doing. 

Screen Shot 2019-03-29 at 6.55.36 pm.png

Screen Shot 2019-03-29 at 6.55.24 pm.png

Share this post


Link to post
Share on other sites

Heres an example file for you to look at, RE the object not been on the surface, if you look at the xpDynamics tag the radius is default set to 5, that is the actual size of the particles so they are hitting the floor first.

 

sphere break.c4d

Share this post


Link to post
Share on other sites
8 hours ago, Mike Batchelor said:

Heres an example file for you to look at, RE the object not been on the surface, if you look at the xpDynamics tag the radius is default set to 5, that is the actual size of the particles so they are hitting the floor first.

 

sphere break.c4d

I'll take a look.Thanks for the quick response

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Mike Batchelor said:

Heres an example file for you to look at, RE the object not been on the surface, if you look at the xpDynamics tag the radius is default set to 5, that is the actual size of the particles so they are hitting the floor first.

 

sphere break.c4d

I did take a look but there are still lots of intersections. Comparing this with the inbuilt fracture and dynamics which doesn't have these issues. Could it be my hardware. Also the sneak peek seemed much more stable and quicker than what I am achieving. Also using the push means the shards move constantly away from one another rather than settling into a heap

 

Edited by Richard Squires

Share this post


Link to post
Share on other sites

It is happening something similar to me. It is working slow.

Also when I apply the xpdynamic tag to a cloner it's not working properly. I've tried to use the xpPPCollision Object, the xpConstraints or the xpFluidPBD, as is suggested for the xpShatter, to make the particles collide with each other but it's not working properly, Which is the way to proceed with cloners? 

It's very promising to be able to work whit all kind of simmulations together (dynamics, cloth, xplosia, fluids, shatter) but in the presentation video for the "X-Particles Early Access Update - xpDynamics presentation"  https://www.youtube.com/watch?v=in5Mig-Rvnc, in the minute 2'38'' seems to be easier and faster than what I'm achieving.

I want to dig more with all the new features.

Share this post


Link to post
Share on other sites

I’ve got the same problem over here. It’s an early release. Can’t wait to play once all the bugs are out. 

Share this post


Link to post
Share on other sites
On 4/23/2019 at 6:50 PM, Emilio Valenzuela said:

It is happening something similar to me. It is working slow.

Also when I apply the xpdynamic tag to a cloner it's not working properly. I've tried to use the xpPPCollision Object, the xpConstraints or the xpFluidPBD, as is suggested for the xpShatter, to make the particles collide with each other but it's not working properly, Which is the way to proceed with cloners? 

It's very promising to be able to work whit all kind of simmulations together (dynamics, cloth, xplosia, fluids, shatter) but in the presentation video for the "X-Particles Early Access Update - xpDynamics presentation"  https://www.youtube.com/watch?v=in5Mig-Rvnc, in the minute 2'38'' seems to be easier and faster than what I'm achieving.

I want to dig more with all the new features.

I have the same issue - the clones just interpenetrate one another and nothing works :(
Any suggestions?

XP-Dynamics.c4d

Share this post


Link to post
Share on other sites

there are some settings you have to change.

1) within xp dynamics tag uncheck update points to make it rigid body rather than softbody

2) within xp dynamics tag activate push and crank it  up to 100 %

3) most vital - project settings -> xparticles -> substeps at least 2 and iterations 30 collisions 200 help with your file

 

XP-Dynamics2.c4d

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×